SEARCH
Current Location:
>
>
> 9800 plus c-arm

9800 plus c-arm

(16)
(1)

kev

9800 plus c-arm

July 14, 2017 01:29

have a blank left screen, when video cable disconnected says no connection on screen, monitor is on , any advice on why I have nothing on screen, the power supplies check out , have a 7f on video controller showing , shows 5 arrows on boot up on c and stops at 5

Log inor Register

to rate and post a comment

(1)

Raymond Coombs

re: 9800 plus c-arm

July 15, 2017 09:18

check all you fuses on the right (looking from the rear), sounds like you dont have power to the CPU or 4 of the left boards, if you dont have lights on the left half of the rear boards its most likely a fuse

Log inor Register

to rate and post a comment

(24)
(3)

Jesse

re: 9800 plus c-arm

July 15, 2017 09:33

5 Arrows is a loss of connection from monitor cart to generator. Check your interconnect cable. most common is the pins on the cable or the cables inside the connector are broken.

Log inor Register

to rate and post a comment

Service Training, Parts & Technical Support for Siemens & Philips Systems

If you are interested to join, please contact us: info@unisonmedacademy.com. Service Training in CT, PET, MRI, CARDIO, ANGIO, MRI, RF & X-RAY. Specialized in SIEMENS & PHILIPS products.

 

 

Access and use of this site is subject to the terms and conditions of our LEGAL NOTICE & PRIVACY NOTICE
Property of and Proprietary to DOTmed.com, Inc. Copyright ©2001-2017 DOTmed.com, Inc.
ALL RIGHTS RESERVED