Ge Lightspeed QxI Artifacts - Service Technicians Forum

Over 350 Minnesota Auctions End Today - Bid Now

GE LIGHTSPEED Qx/i artifacts

Tags: CT, GE HEALTHCARE

(7)
(2)

Saud Romero

GE LIGHTSPEED Qx/i artifacts

April 05, 2021 11:51

Hi, I’m having tons of artifacts with this GE system, I’ve checked if there wasn’t bubbles inside the tube and it seems fine. I’ve checked every power supply and they also seem fine from the detector.
Can anyone please help me out?
I can share some photos.

Thank you.

Log inor Register

to rate and post a comment

(7)
(1)

Tony Scott

re: GE LIGHTSPEED Qx/i artifacts

April 06, 2021 10:44

Take a look at your calumniator. In the bottom is the gold filter that over time can fall apart. If your seeing odd ring artifacts, that's the next place. I've had this at least 4 times. The real issue is which calumniator do you have. If the filter is damaged, you may have to replace the whole thing. The older ones for the QXI are all one part. The newer version you can swap the filter. Also look for oil drops on the filter. The oil gets in there from the gears that open the shutter. You can clean that off, but be very very careful the filter is very thin.

Log inor Register

to rate and post a comment

Servicing GE, Philips and Siemens CT equipment with OEM trained engineers

Numed, a well established company in business since 1975 provides a wide range of service options including time & material service, PM only contracts, full service contracts, labor only contracts & system relocation. Call 800 96 Numed for more info.

advertisement

 

Hitachi

 

RSTI Newsletter

Upcoming Auction Events

Tekyard Medical
TIMED Ending Soon
Apr 19, 2021 (351 lots)