Has Anyone Encountered This Problem With A Toshiba Aquilion - Service Technicians Forum

Has anyone encountered this problem with a Toshiba Aquilion?

Tags: CT, TOSHIBA

Ryan Schock

Has anyone encountered this problem with a Toshiba Aquilion?

April 21, 2017 10:14

The machine is an Aquilion 64 with the SRU and MUDAT. On cold start, the machine boots up fine and the warmup works. The scanogram works. If a regular scan is confirmed at any rotation speed, the scan is terminated before the scan button illuminates with "error in offset data acquisition. Retry acquisition. Code 0xb1810000". If the scan is continually confirmed, the scan button will eventually illuminate. When the scan button is pushed the scanner beeps once and the scan is terminated with very little scan data acquired, the image is barely there, and several more errors are displayed. "The data transfer system in the gantry is abnormal. Contact your service representative immediately. Code 0xb7100020", "abnormal XC status. Code 0xb2100003", "Error in PRE code 0xc0010016" & "The communication error occurred by the data transfer unit in the gantry, and raw data was corrected. Code 0x00000010". If scanning is attempted again and again the scan time before the abort gets longer. The XC error, and the error in PRE appear less frequently and then not at all. The images have streak artifacts and sometimes look diagnostic when the scan completes without abort. Almost every time a part is replaced in the data transfer section, the errors go away and the scanner seems to operate normally with no errors & no artifacts until cold start. The error lights on the GCIFV1 indicate error in RS0 - RS11, S.LVDS0, and S.LVDS1. The errors can also be observed from the GTS terminal and are MUDAT errors. The ROTSOT area has been taken apart and cleaned extensively and the scanner operated normally until cold start. The GCIFV1, GCIFV2, OPCONTV1, OPCONTV2, and the DAS controller board have been replaced, the problem keeps coming back at cold start, and intermittently. The work on the rotating part of the gantry and the ROTSOT area seem to have more of an effect on the issue but because the problem is intermittent to begin with it is hard to make a determination.

Log inor Register

to rate and post a comment

(82)
(17)

Uldis Verdins

re: Has anyone encountered this problem with a Toshiba Aquilion?

April 23, 2017 10:22

Hi Ryan!
In me opinion, problem`s coming from Power supplay`s side.
You must clean sleeprings and check all Gantry power supplay`s. If normal voltage must be 3,3V You need to adjust 3,8V at Power supply or check voltages on board norm + 10-20% more; 5V adjust to 5,2V (on board) and all other to.
When You start check DAS power supply You need to know - after adjusting DAS voltade`s You must to do full Whater/ Air calibration.
Wery important power supply placed near HV inverter box as separated module. After 4-5 working year this power supply go week (not stabile and precise 24V) and need to change or repair. Check please as first. Ofset error is one simptom of this issue.
Best Regard.

Log inor Register

to rate and post a comment

Ryan Schock

re: re: Has anyone encountered this problem with a Toshiba Aquilion?

April 24, 2017 06:29

Thank you very much Uldis!!!!

Log inor Register

to rate and post a comment

(6)

raff cozzolino

re: Has anyone encountered this problem with a Toshiba Aquilion?

April 23, 2017 10:25

The problem may be due to malfunctions of power supplies in R. PSU ASSY cod. PX79-13140 GR.1 (24 VDC, 5VDC and 3,3 VDC)located in the rotating part, near and to the right of the DAS with X-RAY tube at six o'clock, it is very difficult to remove the module, it must first be disconnected and scraped from the front of the Gantry and then removed from the back, Or it may be the DAS power supply DAS PUS ASSY cod. PX79-13120 GR.1 also this is placed on the rotating part and you have to remove it from the back of the Gantry. Among the two the first I mentioned is what can be wrong
Good luck

Log inor Register

to rate and post a comment

Ryan Schock

re: re: Has anyone encountered this problem with a Toshiba Aquilion?

April 24, 2017 06:29

Thank you very much Raff!

Log inor Register

to rate and post a comment

(2)

Hugo Marek

re: Has anyone encountered this problem with a Toshiba Aquilion?

March 11, 2020 09:16

Hi Ryan, I am having almost the same issue. Have you fix the system? I would appreciate your help. Best regards.

Log inor Register

to rate and post a comment

Service. Consulting. Refurbished Imaging Systems

Southwestern Imaging Systems & Service (SWISS) provides fully refurbished medical imaging equipment in addition to a broad range of related services for a dependable and economically smart alternative to OEM programs. www.swissnm.com. 888-295-2367.

advertisement

 

Hitachi

 

RSTI Newsletter

 

one source